aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1997-02-02 07:20:38 +0000
committerEric S. Raymond <esr@thyrsus.com>1997-02-02 07:20:38 +0000
commit2be1639518a932a1d42989df6b1aae2ab9fc7d0d (patch)
treee9181f5aeea78b608ba354d7da3e287e2a296326
parent945a2b9e9135a2c94bcb2d0a033c5d1a0ef6b57f (diff)
downloadfetchmail-2be1639518a932a1d42989df6b1aae2ab9fc7d0d.tar.gz
fetchmail-2be1639518a932a1d42989df6b1aae2ab9fc7d0d.tar.bz2
fetchmail-2be1639518a932a1d42989df6b1aae2ab9fc7d0d.zip
Dave Bodenstab's fixes.
svn path=/trunk/; revision=855
-rw-r--r--Makefile.in2
-rw-r--r--NEWS6
-rw-r--r--fetchmail.c2
-rw-r--r--rcfile_y.y2
-rw-r--r--report.c5
5 files changed, 11 insertions, 6 deletions
diff --git a/Makefile.in b/Makefile.in
index 8bfb1e77..d881b808 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -4,7 +4,7 @@
# So just uncomment all the lines marked QNX.
VERS=3.3
-PL=0
+PL=1
# Ultrix 2.2 make doesn't expand the value of VPATH.
srcdir = @srcdir@
diff --git a/NEWS b/NEWS
index 35bd8e16..19686272 100644
--- a/NEWS
+++ b/NEWS
@@ -1,6 +1,12 @@
Release Notes:
------------------------------------------------------------------------------
+
+pl 3.3.1 (Sun Feb 2 02:17:07 EST 1997):
+* Fix incorrect stripcr processing
+* Unapply a patch that broke error logging to files.
+
+------------------------------------------------------------------------------\
fetchmail-3.3 (Sat Feb 1 15:15:13 EST 1997)
features --
diff --git a/fetchmail.c b/fetchmail.c
index 47fcfe72..39f70074 100644
--- a/fetchmail.c
+++ b/fetchmail.c
@@ -632,7 +632,7 @@ static int load_params(int argc, char **argv, int optind)
/* if stripcr hasn't been set, default it asccording to MDA */
if (ctl->stripcr == -1)
- ctl->stripcr = !ctl->mda;
+ ctl->stripcr = (ctl->mda != (char *)NULL);
/* plug in the semi-standard way of indicating a mail address */
if (ctl->server.envelope == (char *)NULL)
diff --git a/rcfile_y.y b/rcfile_y.y
index e9a381b0..693bcb9e 100644
--- a/rcfile_y.y
+++ b/rcfile_y.y
@@ -355,6 +355,7 @@ static void prc_register(void)
FLAG_FORCE(flush);
FLAG_FORCE(fetchall);
FLAG_FORCE(no_rewrite);
+ FLAG_FORCE(stripcr);
FLAG_FORCE(limit);
FLAG_FORCE(fetchlimit);
FLAG_FORCE(batchlimit);
@@ -396,6 +397,7 @@ void optmerge(struct query *h2, struct query *h1)
FLAG_MERGE(flush);
FLAG_MERGE(fetchall);
FLAG_MERGE(no_rewrite);
+ FLAG_MERGE(stripcr);
FLAG_MERGE(limit);
FLAG_MERGE(fetchlimit);
FLAG_MERGE(batchlimit);
diff --git a/report.c b/report.c
index 5b3fdd52..f6fbd765 100644
--- a/report.c
+++ b/report.c
@@ -436,10 +436,7 @@ error_complete (status, errnum, message, va_alist)
exit(status);
}
else
- if (partial_message_size_used != 0)
- error (status, errnum, "%s", partial_message);
- else
- error (status, errnum, "");
+ error (status, errnum, "%s", partial_message);
}
}