aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1999-02-28 00:31:27 +0000
committerEric S. Raymond <esr@thyrsus.com>1999-02-28 00:31:27 +0000
commit2a2c3129e436d7560de8dcfdd11191cfa6506a92 (patch)
tree4e7c7cbe8887c4c4b55d7bc053c88823197da5f6
parentd4c2c187a478cdfbd55cb262ba8845930764c861 (diff)
downloadfetchmail-2a2c3129e436d7560de8dcfdd11191cfa6506a92.tar.gz
fetchmail-2a2c3129e436d7560de8dcfdd11191cfa6506a92.tar.bz2
fetchmail-2a2c3129e436d7560de8dcfdd11191cfa6506a92.zip
Ready to ship 5.0.0.
svn path=/trunk/; revision=2393
-rw-r--r--INSTALL3
-rw-r--r--Makefile.in2
-rw-r--r--NEWS8
-rw-r--r--env.c20
-rw-r--r--fetchmail.c2
-rw-r--r--fetchmail.man2
-rwxr-xr-xfetchmailconf2
-rw-r--r--imap.c8
-rw-r--r--rcfile_l.l2
9 files changed, 31 insertions, 18 deletions
diff --git a/INSTALL b/INSTALL
index 54b25382..2d980995 100644
--- a/INSTALL
+++ b/INSTALL
@@ -109,7 +109,8 @@ Run
make
This should compile fetchmail for your system. If fetchmail fails to build
-properly, see the FAQ section B on build-time problems.
+properly, see the FAQ section B on build-time problems. Note: parallelized
+make (e.g. make -j 4) fails due to some weirdness in the yacc productions.
4. INSTALL
diff --git a/Makefile.in b/Makefile.in
index e042233a..8ba0a55e 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -4,7 +4,7 @@
# So just uncomment all the lines marked QNX.
PACKAGE = fetchmail
-VERSION = 4.7.8
+VERSION = 5.0.0
SUBDIRS = @INTLSUB@ @POSUB@
diff --git a/NEWS b/NEWS
index 68389020..c5b251fe 100644
--- a/NEWS
+++ b/NEWS
@@ -6,6 +6,12 @@
Release Notes:
+fetchmail-5.0.0 ():
+* Patch by Dan Root to solve an endianness problem in IMAP-K4.
+* Fix lexical-analyzer bug that rejected `set nobouncemail',
+
+There are 262 people on fetchmail-friends and 356 on fetchmail-announce.
+
fetchmail-4.7.8 (Mon Feb 22 10:06:04 EST 1999):
* FreeBSD support for interface and monitor options by Andy Doran <ad@psn.ie>.
* Fixed server-deletion bug in fetchmailconf. Also, handle `port' properly.
@@ -15,7 +21,7 @@ fetchmail-4.7.8 (Mon Feb 22 10:06:04 EST 1999):
postmaster.
* Suppress dancing progress dots when syslog is on.
* es.po update by Javier Kohen.
-* Added FAQ material on what to do for a "do not relay" sendmail error.
+* Added FAQ material on what to do for a "do not relay" sendmail response.
* Can now build under Lynx 3.0.0.
There are 261 people on fetchmail-friends and 358 on fetchmail-announce.
diff --git a/env.c b/env.c
index 2e8749ff..4b0df547 100644
--- a/env.c
+++ b/env.c
@@ -168,20 +168,20 @@ const char *showproto(int proto)
{
switch (proto)
{
- case P_AUTO: return("auto"); break;
+ case P_AUTO: return("auto");
#ifdef POP2_ENABLE
- case P_POP2: return("POP2"); break;
+ case P_POP2: return("POP2");
#endif /* POP2_ENABLE */
- case P_POP3: return("POP3"); break;
- case P_IMAP: return("IMAP"); break;
- case P_IMAP_K4: return("IMAP-K4"); break;
+ case P_POP3: return("POP3");
+ case P_IMAP: return("IMAP");
+ case P_IMAP_K4: return("IMAP-K4");
#ifdef GSSAPI
- case P_IMAP_GSS: return("IMAP-GSS"); break;
+ case P_IMAP_GSS: return("IMAP-GSS");
#endif /* GSSAPI */
- case P_APOP: return("APOP"); break;
- case P_RPOP: return("RPOP"); break;
- case P_ETRN: return("ETRN"); break;
- default: return("unknown?!?"); break;
+ case P_APOP: return("APOP");
+ case P_RPOP: return("RPOP");
+ case P_ETRN: return("ETRN");
+ default: return("unknown?!?");
}
}
diff --git a/fetchmail.c b/fetchmail.c
index cfbbb863..11d3d9da 100644
--- a/fetchmail.c
+++ b/fetchmail.c
@@ -1284,7 +1284,6 @@ static int query_host(struct query *ctl)
}
ctl->server.protocol = P_AUTO;
return(st);
- break;
case P_POP2:
#ifdef POP2_ENABLE
return(doPOP2(ctl));
@@ -1314,7 +1313,6 @@ static int query_host(struct query *ctl)
report(stderr, _("IMAP support is not configured.\n"));
return(PS_PROTOCOL);
#endif /* IMAP_ENABLE */
- break;
case P_ETRN:
#ifndef ETRN_ENABLE
report(stderr, _("ETRN support is not configured.\n"));
diff --git a/fetchmail.man b/fetchmail.man
index 8005cc6e..876a44be 100644
--- a/fetchmail.man
+++ b/fetchmail.man
@@ -962,7 +962,7 @@ T}
set postmaster \& T{
Give the name of the last-resort mail recipient
T}
-set nobouncemail \& T{
+set no bouncemail \& T{
Direct error mail to postmaster rather than sender
T}
set logfile \& T{
diff --git a/fetchmailconf b/fetchmailconf
index 247d9ef4..52682593 100755
--- a/fetchmailconf
+++ b/fetchmailconf
@@ -1046,7 +1046,7 @@ class ServerEdit(Frame, MyWidget):
rightwin.pack(side=LEFT, anchor=N);
def autoprobe(self):
- # Note: this only handles case (1) near fetchmail.c:892
+ # Note: this only handles case (1) near fetchmail.c:1032
# We're assuming people smart enough to set up ssh tunneling
# won't need autoprobing.
if self.server.via:
diff --git a/imap.c b/imap.c
index 3332cd3b..ad654320 100644
--- a/imap.c
+++ b/imap.c
@@ -239,6 +239,14 @@ static int do_rfc1731(int sock, char *truename)
return result;
}
+ /* this patch by Dan Root <dar@thekeep.org> solves an endianess problem. */
+ {
+ char tmp[4];
+
+ *(int *)tmp = ntohl(*(int *) challenge1.cstr);
+ memcpy(challenge1.cstr, tmp, sizeof(tmp));
+ }
+
len = from64tobits(challenge1.cstr, buf1);
if (len < 0) {
report(stderr, _("could not decode initial BASE64 challenge\n"));
diff --git a/rcfile_l.l b/rcfile_l.l
index 92466316..f275e5a6 100644
--- a/rcfile_l.l
+++ b/rcfile_l.l
@@ -78,7 +78,7 @@ to { return TO; }
= { return MAP; }
"*" { return WILDCARD; }
-no/[kfrsduc \t].* { return NO;}
+no/[a-z \t].* { return NO;}
keep { return KEEP; }
flush { return FLUSH; }