aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2007-06-10 08:51:36 +0000
committerMatthias Andree <matthias.andree@gmx.de>2007-06-10 08:51:36 +0000
commit2829d91cb807252dec5c843f8fb1fb38fb34cd07 (patch)
treeecb9f1ffa6abc5410e66bf3816e2cd1364f2be34
parentf54c5666b6ed9f1c2859b9ef39a4f7b4e4970486 (diff)
downloadfetchmail-2829d91cb807252dec5c843f8fb1fb38fb34cd07.tar.gz
fetchmail-2829d91cb807252dec5c843f8fb1fb38fb34cd07.tar.bz2
fetchmail-2829d91cb807252dec5c843f8fb1fb38fb34cd07.zip
Check for dn_skipname() when checking res_search() to resolve µClibc compile failures.
This works by disabling the DNS alias detection feature, which is however deprecated anyways. svn path=/branches/BRANCH_6-3/; revision=5106
-rw-r--r--NEWS9
-rw-r--r--TODO.txt2
-rw-r--r--configure.ac4
3 files changed, 11 insertions, 4 deletions
diff --git a/NEWS b/NEWS
index 7254aea3..8ff95f4d 100644
--- a/NEWS
+++ b/NEWS
@@ -44,6 +44,15 @@ be removed from a 6.4.0 or newer release.)
fetchmail 6.3.X (not yet released, may become .8.1 or .9):
+# FIXES:
+* The configure script will additionally check for 'dn_skipname', to fix build
+ failures with µClibc. The new check still recognizes the resolver libraries on
+ Ubuntu 7.04, openSUSE 10.2, Solaris 8, NetBSD 3.0 and FreeBSD 6.2.
+ Fixes Gentoo bug #134187.
+ NOTE: this is a bit of a hack, since we twist the HAVE_RES_SEARCH result, but
+ res_search() and dn_skipname() are only used together and scheduled for
+ removal in future versions, so this is probably fine.
+
# TRANSLATION UPDATES:
* Polish (Jakub Bogusz)
* Japanese (Takeshi Hamasaki)
diff --git a/TODO.txt b/TODO.txt
index f34970ca..2fe555c4 100644
--- a/TODO.txt
+++ b/TODO.txt
@@ -2,8 +2,6 @@ soon:
- mark fetchmail -vvv in the FAQ
- find a solution for the "invalid header" discards message problem
(escape headers and stuff reminder into body)
-- use workaround for µClibc issue (extend configure.ac check)
- https://bugs.gentoo.org/show_bug.cgi?id=134187
- https://bugzilla.novell.com/show_bug.cgi?id=247233
(same as http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=421446)
might be our fallback of setting sslproto to ""? But what triggers it?
diff --git a/configure.ac b/configure.ac
index db381db3..efb6ba15 100644
--- a/configure.ac
+++ b/configure.ac
@@ -195,10 +195,10 @@ for lib in '' -lresolv; do
#include <resolv.h>
#endif
extern int res_search();
-]], [[res_search(0, 0, 0, 0, 0);]])],
+]], [[res_search(0, 0, 0, 0, 0); dn_skipname(0,0);]])],
[AC_MSG_RESULT([found])
AC_DEFINE(HAVE_RES_SEARCH, [1],
- [Define to 1 if you have the 'res_search' function.])
+ [Define to 1 if you have the 'res_search' and 'dn_skipname' functions.])
break], [AC_MSG_RESULT([not found])])
LIBS=$old_LIBS
done