aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1999-06-11 22:33:42 +0000
committerEric S. Raymond <esr@thyrsus.com>1999-06-11 22:33:42 +0000
commit21708c2d324e0ef6d0f5a0e2e3db325e45bb5ed3 (patch)
treead31000031839dd217d4d2477205dee412b6bd21
parentfcad7f152c6407c492c8fa0989ec23eaeca4bc27 (diff)
downloadfetchmail-21708c2d324e0ef6d0f5a0e2e3db325e45bb5ed3.tar.gz
fetchmail-21708c2d324e0ef6d0f5a0e2e3db325e45bb5ed3.tar.bz2
fetchmail-21708c2d324e0ef6d0f5a0e2e3db325e45bb5ed3.zip
Ready to release.
svn path=/trunk/; revision=2494
-rw-r--r--Makefile.in2
-rw-r--r--NEWS6
-rw-r--r--fetchmail.man12
-rw-r--r--uid.c3
4 files changed, 8 insertions, 15 deletions
diff --git a/Makefile.in b/Makefile.in
index c54f918c..be879541 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -4,7 +4,7 @@
# So just uncomment all the lines marked QNX.
PACKAGE = fetchmail
-VERSION = 5.0.3
+VERSION = 5.0.4
SUBDIRS = @INTLSUB@ @POSUB@
diff --git a/NEWS b/NEWS
index d5f0cc86..1c5d698f 100644
--- a/NEWS
+++ b/NEWS
@@ -8,7 +8,7 @@
Release Notes:
-fetchmail-5.1.0 ():
+fetchmail-5.0.4 (Fri Jun 11 18:32:58 EDT 1999):
* Fixed compilation error on systems without vnsprintf.
* No more GIFs! RPM is now patent-encumbrance-free.
* Fix yet another annoying qmail \n bug (thanks to Paul Gilmore).
@@ -16,8 +16,10 @@ fetchmail-5.1.0 ():
* Added qpopper 2.53 warning to the FAQ and fetchmailconf.
* Fix fetchmailconf to handle window-manager destroy notifications.
* Todd <tastas@home.com> Sabin's RFC2195 support for AUTH=CRAM-MD5 under IMAP.
+* New FAQ material on single-drop use with Daemon, thanks to Phil Hunt.
+* Fix memory leak triggered by UIDL usage, and a .fetchids-trashing bug.
-There are 260 people on fetchmail-friends and 387 on fetchmail-announce.
+There are 261 people on fetchmail-friends and 407 on fetchmail-announce.
fetchmail-5.0.3 (Sun May 2 23:39:22 EDT 1999):
* Added FAQ item about things to check if --monitor fails with pppd.
diff --git a/fetchmail.man b/fetchmail.man
index 11871d53..3896971c 100644
--- a/fetchmail.man
+++ b/fetchmail.man
@@ -207,10 +207,7 @@ machine in the server's queue of undelivered mail.
Force UIDL use (effective only with POP3). Force client-side tracking
of `newness' of messages (UIDL stands for ``unique ID listing'' and is
described in RFC1725). Use with `keep' to use a mailbox as a baby
-news drop for a group of users. Note: the implementation of this
-feature is fragile. If you poll with a host specified on the command line,
-your saved data about seen-message UIDLs on \fIother\fR hosts is liable
-to get clobbered.
+news drop for a group of users.
.TP
.B \-P, --port
(Keyword: port)
@@ -1794,13 +1791,6 @@ The RFC822 address parser used in multidrop mode chokes on some
@-addresses that are technically legal but bizarre. Strange uses of
quoting and embedded comments are likely to confuse it.
.PP
-Two users have reported that daemon-mode fetchmails leak memory.
-This may be associated with use of UIDL, or it may mean your TCP/IP
-layer is failing to garbage-collect closed sockets generated on
-protocol errors properly; most installations do not have this
-problem. If you observe it, please report a bug. The workaround is
-to do a fetchmail -q and restart occasionally.
-.PP
In a message with multiple envelope headers, only the last one
processed will be visible to fetchmail. To get around this, use a
mailserver-side filter that consolidates the contents of all envelope
diff --git a/uid.c b/uid.c
index 8cf753d0..09ea5684 100644
--- a/uid.c
+++ b/uid.c
@@ -332,6 +332,7 @@ void update_str_lists(struct query *ctl)
/* perform end-of-query actions on UID lists */
{
free_str_list(&ctl->oldsaved);
+ free_str_list(&scratchlist);
ctl->oldsaved = ctl->newsaved;
ctl->newsaved = (struct idlist *) NULL;
@@ -364,7 +365,7 @@ void write_saved_lists(struct query *hostlist, const char *idfile)
}
/* either nuke the file or write updated last-seen IDs */
- if (!idcount)
+ if (!idcount && !scratchlist)
{
if (outlevel >= O_DEBUG)
report(stdout, "Deleting fetchids file.\n");