aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1999-06-12 23:02:37 +0000
committerEric S. Raymond <esr@thyrsus.com>1999-06-12 23:02:37 +0000
commit1f00c246cf0327c33ee2a711cc01467598c9861f (patch)
treeb17359ff6e1fa634413b79d692cda52158545615
parent7bf74d9aba6d96eac8011fc96b1c3fc8dba9e422 (diff)
downloadfetchmail-1f00c246cf0327c33ee2a711cc01467598c9861f.tar.gz
fetchmail-1f00c246cf0327c33ee2a711cc01467598c9861f.tar.bz2
fetchmail-1f00c246cf0327c33ee2a711cc01467598c9861f.zip
OpenBSD port patches.
svn path=/trunk/; revision=2499
-rw-r--r--NEWS5
-rwxr-xr-xconfig.guess18
-rw-r--r--configure.in6
-rw-r--r--driver.c2
-rw-r--r--i18n.h1
-rw-r--r--imap.c2
6 files changed, 29 insertions, 5 deletions
diff --git a/NEWS b/NEWS
index 1c5d698f..a633257f 100644
--- a/NEWS
+++ b/NEWS
@@ -8,6 +8,11 @@
Release Notes:
+fetchmail-5.1.0 ():
+* Merged in official OpenBSD port patches.
+
+There are 261 people on fetchmail-friends and 408 on fetchmail-announce.
+
fetchmail-5.0.4 (Fri Jun 11 18:32:58 EDT 1999):
* Fixed compilation error on systems without vnsprintf.
* No more GIFs! RPM is now patent-encumbrance-free.
diff --git a/config.guess b/config.guess
index 5b40242f..353f9d9d 100755
--- a/config.guess
+++ b/config.guess
@@ -65,6 +65,9 @@ case "${UNAME_MACHINE}:${UNAME_SYSTEM}:${UNAME_RELEASE}:${UNAME_VERSION}" in
amiga:NetBSD:*:*)
echo m68k-cbm-netbsd${UNAME_RELEASE}
exit 0 ;;
+ amiga:OpenBSD:*:*)
+ echo m68k-cbm-openbsd${UNAME_RELEASE}
+ exit 0 ;;
arm:RISC*:1.[012]*:*|arm:riscix:1.[012]*:*)
echo arm-acorn-riscix${UNAME_RELEASE}
exit 0;;
@@ -102,12 +105,21 @@ case "${UNAME_MACHINE}:${UNAME_SYSTEM}:${UNAME_RELEASE}:${UNAME_VERSION}" in
atari*:NetBSD:*:*)
echo m68k-atari-netbsd${UNAME_RELEASE}
exit 0 ;;
+ atari*:OpenBSD:*:*)
+ echo m68k-atari-openbsd${UNAME_RELEASE}
+ exit 0 ;;
sun3*:NetBSD:*:*)
echo m68k-sun-netbsd${UNAME_RELEASE}
exit 0 ;;
+ sun3*:OpenBSD:*:*)
+ echo m68k-sun-openbsd${UNAME_RELEASE}
+ exit 0 ;;
mac68k:NetBSD:*:*)
echo m68k-apple-netbsd${UNAME_RELEASE}
exit 0 ;;
+ mac68k:OpenBSD:*:*)
+ echo m68k-apple-openbsd${UNAME_RELEASE}
+ exit 0 ;;
RISC*:ULTRIX:*:*)
echo mips-dec-ultrix${UNAME_RELEASE}
exit 0 ;;
@@ -303,6 +315,9 @@ EOF
hp3[0-9][05]:NetBSD:*:*)
echo m68k-hp-netbsd${UNAME_RELEASE}
exit 0 ;;
+ hp3[0-9][05]:OpenBSD:*:*)
+ echo m68k-hp-openbsd${UNAME_RELEASE}
+ exit 0 ;;
i[34]86:BSD/386:*:* | *:BSD/OS:*:*)
echo ${UNAME_MACHINE}-unknown-bsdi${UNAME_RELEASE}
exit 0 ;;
@@ -312,6 +327,9 @@ EOF
*:NetBSD:*:*)
echo ${UNAME_MACHINE}-unknown-netbsd`echo ${UNAME_RELEASE}|sed -e 's/[-_].*/\./'`
exit 0 ;;
+ *:OpenBSD:*:*)
+ echo ${UNAME_MACHINE}-unknown-openbsd`echo ${UNAME_RELEASE}|sed -e 's/[-_].*/\./'`
+ exit 0 ;;
*:GNU:*:*)
echo `echo ${UNAME_MACHINE}|sed -e 's,/.*$,,'`-unknown-gnu`echo ${UNAME_RELEASE}|sed -e 's,/.*$,,'`
exit 0 ;;
diff --git a/configure.in b/configure.in
index f4cc65f8..54722f86 100644
--- a/configure.in
+++ b/configure.in
@@ -331,10 +331,10 @@ AC_ARG_WITH(kerberos,
# The "elif" arm (nonempty $with_kerberos) is kind of a crock. It works for
# configuring the BSD/OS Kerberos IV support, though.
-# Check for a NetBSD special case
-if test "$with_kerberos" = "yes" -a `uname` = "NetBSD"
+# Check for a NetBSD/OpenBSD special case
+if test "$with_kerberos" = "yes" -a `uname` = "NetBSD" -o `uname` = "OpenBSD"
then
- echo "Configuring kerberosIV for NetBSD"
+ echo "Configuring kerberosIV for `uname`"
CEFLAGS="$CEFLAGS -DKERBEROS_V4 -I/usr/include/kerberosIV"
LIBS="$LIBS -lkrb -ldes"
elif test -n "$with_kerberos" -a -n "$with_kerberos5"
diff --git a/driver.c b/driver.c
index 4acd6ade..e5a32231 100644
--- a/driver.c
+++ b/driver.c
@@ -1160,7 +1160,7 @@ int
kerberos_auth (socket, canonical)
/* authenticate to the server host using Kerberos V4 */
int socket; /* socket to server host */
-#ifdef __FreeBSD__
+#if defined(__FreeBSD__) || defined(__OpenBSD__)
char *canonical; /* server name */
#else
const char *canonical; /* server name */
diff --git a/i18n.h b/i18n.h
index dd08e601..d3c482a3 100644
--- a/i18n.h
+++ b/i18n.h
@@ -1,5 +1,6 @@
/* Dummy header for libintl.h */
+#undef _
#ifdef ENABLE_NLS
#undef __OPTIMIZE__
#include <libintl.h>
diff --git a/imap.c b/imap.c
index c6e3cc8b..31338378 100644
--- a/imap.c
+++ b/imap.c
@@ -293,7 +293,7 @@ static int do_rfc1731(int sock, char *truename)
memcpy(session, credentials.session, sizeof session);
memset(&credentials, 0, sizeof credentials);
- des_key_sched(session, schedule);
+ des_key_sched(&session, schedule);
result = krb_get_tf_fullname(TKT_FILE, tktuser, tktinst, tktrealm);
if (result) {