aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1996-11-18 04:39:34 +0000
committerEric S. Raymond <esr@thyrsus.com>1996-11-18 04:39:34 +0000
commit19b624e18dd1f42acea63dbcbb8026f885da68a8 (patch)
treeff4a30aebb15a68e35514550e8ff90809d4623a8
parent5ad1b858713c3585ec5af9f610c6cb72972d48b8 (diff)
downloadfetchmail-19b624e18dd1f42acea63dbcbb8026f885da68a8.tar.gz
fetchmail-19b624e18dd1f42acea63dbcbb8026f885da68a8.tar.bz2
fetchmail-19b624e18dd1f42acea63dbcbb8026f885da68a8.zip
Fix a bug that prevented installation.
svn path=/trunk/; revision=550
-rw-r--r--Makefile.in21
1 files changed, 2 insertions, 19 deletions
diff --git a/Makefile.in b/Makefile.in
index b865b16a..331dad0c 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -136,31 +136,14 @@ tags: $(tagsrcs)
$(CTAGS) $(tagsrcs)
.PHONY: install installdirs
-install: installdirs \
- $(bindir)/$(instname) $(mandir)/$(instname).$(manext) # $(infodir)/fetchmail.info
+install: installdirs $(bindir)/$(instname) $(mandir)/$(instname).$(manext)
installdirs:
- $(SHELL) ${srcdir}/mkinstalldirs $(bindir) $(mandir) # $(infodir)
+ $(SHELL) ${srcdir}/mkinstalldirs $(bindir) $(mandir)
$(bindir)/$(instname): fetchmail
$(INSTALL_PROGRAM) fetchmail $@
-$(infodir)/fetchmail.info: fetchmail.info
- if [ -r ./fetchmail.info ]; then dir=.; else dir=$(srcdir); fi; \
- for file in $${dir}/fetchmail.info*; do \
- name="`basename $$file`"; \
- $(INSTALL_DATA) $$file \
- `echo $@ | sed "s,fetchmail.info\$$,$$name,"`; \
- done
-# Run install-info only if it exists.
-# Use `if' instead of just prepending `-' to the
-# line so we notice real errors from install-info.
-# We use `$(SHELL) -c' because some shells do not
-# fail gracefully when there is an unknown command.
- if $(SHELL) -c 'install-info --version' >/dev/null 2>&1; then \
- install-info --infodir=$(infodir) $$dir/fetchmail.info; \
- else true; fi
-
$(mandir)/$(instname).$(manext): fetchmail.man
$(INSTALL_DATA) $(srcdir)/fetchmail.man $@