aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2000-08-21 03:35:43 +0000
committerEric S. Raymond <esr@thyrsus.com>2000-08-21 03:35:43 +0000
commit11489caef3f3ae2626fbb0becb19724e8f5839ae (patch)
treec08b2a5e0c2b64a7b77588dcc9570859d802bb0b
parent54f49bce06e961b4868b5bac8a9c1765fd1f2e67 (diff)
downloadfetchmail-11489caef3f3ae2626fbb0becb19724e8f5839ae.tar.gz
fetchmail-11489caef3f3ae2626fbb0becb19724e8f5839ae.tar.bz2
fetchmail-11489caef3f3ae2626fbb0becb19724e8f5839ae.zip
Almost ready to ship 5.5.1
svn path=/trunk/; revision=2952
-rw-r--r--Makefile.in2
-rw-r--r--NEWS8
-rw-r--r--fetchmail-FAQ.html22
-rw-r--r--fetchmail.man3
-rw-r--r--pop3.c2
5 files changed, 31 insertions, 6 deletions
diff --git a/Makefile.in b/Makefile.in
index a75b8b9d..5770beff 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -4,7 +4,7 @@
# So just uncomment all the lines marked QNX.
PACKAGE = fetchmail
-VERSION = 5.5.0
+VERSION = 5.5.1
SUBDIRS = @INTLSUB@ @POSUB@
diff --git a/NEWS b/NEWS
index f8a1c2b8..5b0cfed4 100644
--- a/NEWS
+++ b/NEWS
@@ -2,6 +2,14 @@
(The `lines' figures total .c, .h, .l, and .y files under version control.)
+* Fix a finger error in the dot-termination fix for 5.5.0.
+* Javier Kohen's update for es.po.
+* Jiri Pavlovsky's cs.po update.
+* Added to FAQ item on K3 a recipe using the new plugin %h option.
+* Fixed a nasty typo in FAQ item T1 -- the old version disdn't generate
+ correct Delivered-To hacks. Thanks to "Peter 'Rattacresh' Backes"
+ <rtc@helen.PLASMA.Xg8.DE> for spotting this.
+
------------------------------------------------------------------------------
fetchmail-5.5.0 (Sat Aug 12 12:47:21 EDT 2000), 19241 lines:
diff --git a/fetchmail-FAQ.html b/fetchmail-FAQ.html
index aaeb5f5d..caa9c902 100644
--- a/fetchmail-FAQ.html
+++ b/fetchmail-FAQ.html
@@ -10,7 +10,7 @@
<table width="100%" cellpadding=0><tr>
<td width="30%">Back to <a href="index.html">Fetchmail Home Page</a>
<td width="30%" align=center>To <a href="/~esr/sitemap.html">Site Map</a>
-<td width="30%" align=right>$Date: 2000/07/27 20:24:24 $
+<td width="30%" align=right>$Date: 2000/08/21 03:35:41 $
</table>
<HR>
<H1>Frequently Asked Questions About Fetchmail</H1>
@@ -1054,7 +1054,7 @@ If you want to support multidrop mode, and you can get access to your
mailserver's sendmail.cf file, it's a good idea to add this rule:<P>
<pre>
-H?l?Delivered-To: $u
+H?l?Delivered-To: $h
</pre>
and declare `<CODE>envelope "Delivered-To:"</CODE>'. This will cause the
@@ -1659,7 +1659,7 @@ http://www.bieringer.de/linux/IPv6/IPv6-HOWTO/IPv6-HOWTO.html</a>
<hr>
<h2><a name="K3">K3. How can I get fetchmail to work with ssh?</a></h2>
-We have four recipes for this.<P>
+We have five recipes for this.<P>
<h3>Single-User POP3</h3>
@@ -1841,6 +1841,20 @@ bound for along timeout and has timing issues requiring tricks like
sleep, etc. I use this method for fetching all the mail for
mimique.com"<P>
+<h3>Using plugin</h3>
+
+Since 5.4.5, there's been a very simple recipe. Use the following option:
+
+<TT>
+ plugin "ssh %h /usr/sbin/rimapd"
+</TT>
+
+You may have to use a different absolute pathname. This option tells
+fetchmail that instead of opening a connection on the server's port
+143 and doing standard IMAP authentication, fetchmail should ssh to
+the server and run rimapd, using the more secure ssh authentication
+(as well as getting ssh's encryption).<p>
+
<hr>
<h2><a name="K4">K4. What do I have to do to use the IMAP-GSS protocol?</a></h2>
@@ -2878,7 +2892,7 @@ install Linux on your server...<p>
<table width="100%" cellpadding=0><tr>
<td width="30%">Back to <a href="index.html">Fetchmail Home Page</a>
<td width="30%" align=center>To <a href="/~esr/sitemap.html">Site Map</a>
-<td width="30%" align=right>$Date: 2000/07/27 20:24:24 $
+<td width="30%" align=right>$Date: 2000/08/21 03:35:41 $
</table>
<P><ADDRESS>Eric S. Raymond <A HREF="mailto:esr@thyrsus.com">&lt;esr@snark.thyrsus.com&gt;</A></ADDRESS>
diff --git a/fetchmail.man b/fetchmail.man
index 730b89a1..d45aff5f 100644
--- a/fetchmail.man
+++ b/fetchmail.man
@@ -1122,6 +1122,9 @@ proto[col] -p T{
Specify protocol (case insensitive):
POP2, POP3, IMAP, IMAP-K4, IMAP-GSS, APOP, KPOP
T}
+local[domains] \& T{
+Specify domain(s) to be regarded as local
+T}
port -P T{
Specify TCP/IP service port
T}
diff --git a/pop3.c b/pop3.c
index 73da12d3..39da35c2 100644
--- a/pop3.c
+++ b/pop3.c
@@ -157,7 +157,7 @@ int pop3_getauth(int sock, struct query *ctl, char *greeting)
while ((ok = gen_recv(sock, buffer, sizeof(buffer))) == 0)
{
- if (DOTLINE([0]))
+ if (DOTLINE(buffer))
break;
if (strncasecmp(buffer, "rpa", 3) == 0)
has_rpa = TRUE;