aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2005-07-03 18:16:46 +0000
committerMatthias Andree <matthias.andree@gmx.de>2005-07-03 18:16:46 +0000
commit0d89042e41405763ae734174e55aa0fd2c8eeaec (patch)
tree53884c1172aab2f99729f40c34c1056610e622d3
parenta92c8c212e2f1e014166cfb84751ea052035599e (diff)
downloadfetchmail-0d89042e41405763ae734174e55aa0fd2c8eeaec.tar.gz
fetchmail-0d89042e41405763ae734174e55aa0fd2c8eeaec.tar.bz2
fetchmail-0d89042e41405763ae734174e55aa0fd2c8eeaec.zip
Nalin Dahyabhai's fix for driver.c to not call the private Kerberos
krb5_init_ets() function. Sent by Miloslav Trmac. svn path=/trunk/; revision=4070
-rw-r--r--NEWS2
-rw-r--r--driver.c1
2 files changed, 2 insertions, 1 deletions
diff --git a/NEWS b/NEWS
index f0105047..3b4c5564 100644
--- a/NEWS
+++ b/NEWS
@@ -78,6 +78,8 @@ fetchmail 6.3.0 (not yet released officially):
* configure.ac cleanups by Miloslav Trmac (Matthias Andree)
* Miloslav Trmac's fix to reply_hack() type, for systems where
sizeof(int) != sizeof(size_t). (Matthias Andree)
+* Nalin Dahyabhai's fix for driver.c to not call the private Kerberos
+ krb5_init_ets() function. Sent by Miloslav Trmac. (Matthias Andree)
fetchmail-6.2.5 (Wed Oct 15 18:39:22 EDT 2003), 23079 lines:
diff --git a/driver.c b/driver.c
index 008a7fa8..eb972bd9 100644
--- a/driver.c
+++ b/driver.c
@@ -211,7 +211,6 @@ const char *canonical; /* server name */
krb5_auth_context auth_context = NULL;
krb5_init_context(&context);
- krb5_init_ets(context);
krb5_auth_con_init(context, &auth_context);
if (retval = krb5_cc_default(context, &ccdef)) {