aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2001-03-02 22:01:54 +0000
committerEric S. Raymond <esr@thyrsus.com>2001-03-02 22:01:54 +0000
commit0a189aa7a891d6aa23d29c38a0fccc34f1e5b78b (patch)
treeffbe30bcd5b2657f9d863fbec5f54a5bf32442e8
parent22079ecb6aa86ca8ed2ea8952a14823c742eec12 (diff)
downloadfetchmail-0a189aa7a891d6aa23d29c38a0fccc34f1e5b78b.tar.gz
fetchmail-0a189aa7a891d6aa23d29c38a0fccc34f1e5b78b.tar.bz2
fetchmail-0a189aa7a891d6aa23d29c38a0fccc34f1e5b78b.zip
Restore ability to build with NLS.
svn path=/trunk/; revision=3178
-rw-r--r--configure.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 0056e45f..52e99889 100644
--- a/configure.in
+++ b/configure.in
@@ -35,6 +35,7 @@ AC_SUBST(CEFLAGS)
AC_SUBST(LDEFLAGS)
AC_SUBST(LIBOBJS)
AC_SUBST(POMAKE)
+AC_SUBST(LOCALE_DIR)
PACKAGE=`sed -n '/PACKAGE *= *\(.*\)/s//\1/p' <$srcdir/Makefile.in`
AC_DEFINE_UNQUOTED(PACKAGE, "$PACKAGE")
@@ -226,7 +227,13 @@ AC_CHECK_SIZEOF(long)
if test "$USE_NLS" = "yes"
then
echo 'Enabling internationalization support...'
- POMAKE='$(MAKE) -C po'
+ POMAKE='cd po; $(MAKE)'
+ if test "x$prefix" != xNONE; then
+ LOCALE_DIR=$prefix/share/locale
+ else
+ LOCALE_DIR=$ac_default_prefix/share/locale
+ fi
+ EXTRADEFS="$EXTRADEFS -DLOCALEDIR='\"${LOCALE_DIR}\"'"
else
echo 'Disabling internationalization support...'
POMAKE="@echo '(NLS support disabled)'; #"