aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 4 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 6528d79..265afd3 100755
--- a/setup.py
+++ b/setup.py
@@ -1,10 +1,11 @@
-#!/usr/bin/env python
+#! /usr/bin/env python
import sys
def check_python_version():
"""Abort if we are running on python < v2.0"""
- too_old_error = "This program requires python v2.0 or greater."
+ too_old_error = """This program requires python v2.0 or greater.
+Your version of python is: %s""" % sys.version
try:
version = sys.version_info # we might not even have this function! :)
if (version[0] < 2):
@@ -18,9 +19,8 @@ check_python_version() # define & run this early - 'distutils.core' is new
from distutils.core import setup
setup(name="archivemail",
- version="0.4.2",
+ version="0.4.3",
description="archive and compress old email",
- platforms="POSIX",
license="GNU GPL",
url="http://archivemail.sourceforge.net/",
author="Paul Rodger",